Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 26, 2026 - 11:00 CET
Scheduled
During this maintenance window we will upgrade The Things Stack Cloud to v3.35.2.
We expect brief service interruptions during this deployment.
Some gateways may temporarily disconnect as services are restarted. Gateways are expected to automatically reconnect, but in some cases this may take up to one hour.
Here is the changelog since the current version 3.35.1:
### Changed
- Rate limiting for downlink queue operations (`DownlinkQueuePush`, `DownlinkQueueReplace`) is now applied at the application level instead of per-device. This may result in more `ResourceExhausted` (429) errors when multiple devices under the same application perform downlink queue operations concurrently.
### Fixed
- The support user is now properly excluded from admin-related operations (notifications, last admin checks for delete/update/purge). - Application Server webhook registry now uses read-only Redis client for non-paginated list operations, reducing connection holding time during high traffic.
Posted Jan 21, 2026 - 10:14 CET
This scheduled maintenance affected: The Things Stack Cloud (Europe 1 (eu1), Europe 2 (eu2), North America 1 (nam1), Australia 1 (au1), Asia 1 (as1)).